// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9]+(?:[.,][0-9]+)*$").unwrap();
let string = "123
1
12
123.0
123.456
1,23,456
1,23,456.56
12,300.56
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}