re = /^[0-9]+(?:[.,][0-9]+)*$/m
str = '123
1
12
123.0
123.456
1,23,456
1,23,456.56
12,300.56
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end