import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9]+(?:[.,][0-9]+)*$";
final String string = "123\n"
+ "1\n"
+ "12\n"
+ "123.0\n"
+ "123.456\n"
+ "1,23,456\n"
+ "1,23,456.56\n"
+ "12,300.56\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}