#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:SO|OS|O[HS]|[SO])(?:\s?[-+*°.1-9]){1,4}"
Local $sString = "O 4 2 -" & @CRLF & _
"O 2 - " & @CRLF & _
"SO 4 * - 2 " & @CRLF & _
"S 2- " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""OO", "SS", and "SH" (and even things like "OOOOOOOO")"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")