re = /\b(?:SO|OS|O[HS]|[SO])(?:\s?[-+*°.1-9]){1,4}/m
str = 'O 4 2 -
O 2 -
SO 4 * - 2
S 2-
"OO", "SS", and "SH" (and even things like "OOOOOOOO")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end