package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:SO|OS|O[HS]|[SO])(?:\s?[-+*°.1-9]){1,4}`)
var str = `O 4 2 -
O 2 -
SO 4 * - 2
S 2-
"OO", "SS", and "SH" (and even things like "OOOOOOOO")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}