// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:SO|OS|O[HS]|[SO])(?:\s?[-+*°.1-9]){1,4}").unwrap();
let string = "O 4 2 -
O 2 -
SO 4 * - 2
S 2-
\"OO\", \"SS\", and \"SH\" (and even things like \"OOOOOOOO\")";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}