using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:SO|OS|O[HS]|[SO])(?:\s?[-+*°.1-9]){1,4}";
string input = @"O 4 2 -
O 2 -
SO 4 * - 2
S 2-
""OO"", ""SS"", and ""SH"" (and even things like ""OOOOOOOO"")";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}