#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\d{6}(?:\d{4})?\b(?!\/)"
Local $sString = "1. My Zip-code is 101010. Please update. -> 101010" & @CRLF & _
"2. 9090909090 is my mobile number -> 9090909090" & @CRLF & _
"3. 00/9090909090/000000/ -> should not find any number" & @CRLF & _
"4. 9090909090 -> 9090909090"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")