const regex = /\b\d{6}(?:\d{4})?\b(?!\/)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{6}(?:\\d{4})?\\b(?!\\\/)', 'gm')
const str = `1. My Zip-code is 101010. Please update. -> 101010
2. 9090909090 is my mobile number -> 9090909090
3. 00/9090909090/000000/ -> should not find any number
4. 9090909090 -> 9090909090`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}