use strict;
my $str = '1. My Zip-code is 101010. Please update. -> 101010
2. 9090909090 is my mobile number -> 9090909090
3. 00/9090909090/000000/ -> should not find any number
4. 9090909090 -> 9090909090';
my $regex = qr/\b\d{6}(?:\d{4})?\b(?!\/)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}