using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d{6}(?:\d{4})?\b(?!\/)";
string input = @"1. My Zip-code is 101010. Please update. -> 101010
2. 9090909090 is my mobile number -> 9090909090
3. 00/9090909090/000000/ -> should not find any number
4. 9090909090 -> 9090909090";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}