$re = '/\b\d{6}(?:\d{4})?\b(?!\/)/m';
$str = '1. My Zip-code is 101010. Please update. -> 101010
2. 9090909090 is my mobile number -> 9090909090
3. 00/9090909090/000000/ -> should not find any number
4. 9090909090 -> 9090909090';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);