#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:http(?:s?):\/\/(?:www\.)?)?([A-Za-z0-9_:.-]+)\/?"
Local $sString = "https://github.com/" & @CRLF & _
"" & @CRLF & _
"https://www.google.com/" & @CRLF & _
"" & @CRLF & _
"https://192.168.1.100:8080/" & @CRLF & _
"" & @CRLF & _
"localhost:8080/" & @CRLF & _
"" & @CRLF & _
"http://153.168.26.5:2168/" & @CRLF & _
"" & @CRLF & _
"http://localhost/phpmyadmin/sql.php" & @CRLF & _
"" & @CRLF & _
"https://fonts.google.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")