using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:http(?:s?):\/\/(?:www\.)?)?([A-Za-z0-9_:.-]+)\/?";
string input = @"https://github.com/
https://www.google.com/
https://192.168.1.100:8080/
localhost:8080/
http://153.168.26.5:2168/
http://localhost/phpmyadmin/sql.php
https://fonts.google.com/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}