re = /^(?:http(?:s?):\/\/(?:www\.)?)?([A-Za-z0-9_:.-]+)\/?/m
str = 'https://github.com/
https://www.google.com/
https://192.168.1.100:8080/
localhost:8080/
http://153.168.26.5:2168/
http://localhost/phpmyadmin/sql.php
https://fonts.google.com/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end