// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:http(?:s?):\/\/(?:www\.)?)?([A-Za-z0-9_:.-]+)\/?").unwrap();
let string = "https://github.com/
https://www.google.com/
https://192.168.1.100:8080/
localhost:8080/
http://153.168.26.5:2168/
http://localhost/phpmyadmin/sql.php
https://fonts.google.com/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}