#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\bCats\s+Dogs\b).*?\bDogs\b"
Local $sString = "My Dogs are happy" & @CRLF & _
"Dogs are humans best friend" & @CRLF & _
"This is invalid Cats Dogs" & @CRLF & _
"The Dogs and Cats and Dogs and Dogs" & @CRLF & _
"The Dogs and Cats and Dogs and Cats Dogs"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")