import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\bCats\\s+Dogs\\b).*?\\bDogs\\b";
final String string = "My Dogs are happy\n"
+ "Dogs are humans best friend\n"
+ "This is invalid Cats Dogs\n"
+ "The Dogs and Cats and Dogs and Dogs\n"
+ "The Dogs and Cats and Dogs and Cats Dogs";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}