re = /^(?!.*\bCats\s+Dogs\b).*?\bDogs\b/m
str = 'My Dogs are happy
Dogs are humans best friend
This is invalid Cats Dogs
The Dogs and Cats and Dogs and Dogs
The Dogs and Cats and Dogs and Cats Dogs'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end