$re = '/^(?!.*\bCats\s+Dogs\b).*?\bDogs\b/m';
$str = 'My Dogs are happy
Dogs are humans best friend
This is invalid Cats Dogs
The Dogs and Cats and Dogs and Dogs
The Dogs and Cats and Dogs and Cats Dogs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);