using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\bCats\s+Dogs\b).*?\bDogs\b";
string input = @"My Dogs are happy
Dogs are humans best friend
This is invalid Cats Dogs
The Dogs and Cats and Dogs and Dogs
The Dogs and Cats and Dogs and Cats Dogs";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}