#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\(?([0-9]{3})\)?[-. ]?([0-9]{3})(?:[-. ]?([0-9]{4}))?(?:[#. ]+([0-9]{1,10}))?$"
Local $sString = "Examples:" & @CRLF & _
"(555) 555-1212" & @CRLF & _
"(555) 555-1212 #12525" & @CRLF & _
" - Acceptable (Up to 10 digits after the # sign)" & @CRLF & _
"5555551212" & @CRLF & _
"555-555-1212" & @CRLF & _
"555-555-1212 #12525" & @CRLF & _
" - Acceptable (Up to 10 digits after the # sign)" & @CRLF & _
"" & @CRLF & _
"Any alpha characters should be Unacceptable" & @CRLF & _
"(555) 555-1212 ext 12525" & @CRLF & _
"(555) 555-1212 x12525" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")