$re = '/^\(?([0-9]{3})\)?[-. ]?([0-9]{3})(?:[-. ]?([0-9]{4}))?(?:[#. ]+([0-9]{1,10}))?$/m';
$str = 'Examples:
(555) 555-1212
(555) 555-1212 #12525
- Acceptable (Up to 10 digits after the # sign)
5555551212
555-555-1212
555-555-1212 #12525
- Acceptable (Up to 10 digits after the # sign)
Any alpha characters should be Unacceptable
(555) 555-1212 ext 12525
(555) 555-1212 x12525
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);