// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\(?([0-9]{3})\)?[-. ]?([0-9]{3})(?:[-. ]?([0-9]{4}))?(?:[#. ]+([0-9]{1,10}))?$").unwrap();
let string = "Examples:
(555) 555-1212
(555) 555-1212 #12525
- Acceptable (Up to 10 digits after the # sign)
5555551212
555-555-1212
555-555-1212 #12525
- Acceptable (Up to 10 digits after the # sign)
Any alpha characters should be Unacceptable
(555) 555-1212 ext 12525
(555) 555-1212 x12525
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}