package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\(?([0-9]{3})\)?[-. ]?([0-9]{3})(?:[-. ]?([0-9]{4}))?(?:[#. ]+([0-9]{1,10}))?$`)
var str = `Examples:
(555) 555-1212
(555) 555-1212 #12525
- Acceptable (Up to 10 digits after the # sign)
5555551212
555-555-1212
555-555-1212 #12525
- Acceptable (Up to 10 digits after the # sign)
Any alpha characters should be Unacceptable
(555) 555-1212 ext 12525
(555) 555-1212 x12525
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}