const regex = /^\(?([0-9]{3})\)?[-. ]?([0-9]{3})(?:[-. ]?([0-9]{4}))?(?:[#. ]+([0-9]{1,10}))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\(?([0-9]{3})\\)?[-. ]?([0-9]{3})(?:[-. ]?([0-9]{4}))?(?:[#. ]+([0-9]{1,10}))?$', 'gm')
const str = `Examples:
(555) 555-1212
(555) 555-1212 #12525
- Acceptable (Up to 10 digits after the # sign)
5555551212
555-555-1212
555-555-1212 #12525
- Acceptable (Up to 10 digits after the # sign)
Any alpha characters should be Unacceptable
(555) 555-1212 ext 12525
(555) 555-1212 x12525
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}