using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[A-Za-z0-9]).{3,30}$";
string input = @"ben
ab
ben
ben_franklin
ben@
%#$
ben#franklin
be'franklin
&%^$@#!*&^";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}