$re = '/^(?=.*[A-Za-z0-9]).{3,30}$/m';
$str = 'ben
ab
ben
ben_franklin
ben@
%#$
ben#franklin
be\'franklin
&%^$@#!*&^';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);