re = /^(?=.*[A-Za-z0-9]).{3,30}$/m
str = 'ben
ab
ben
ben_franklin
ben@
%#$
ben#franklin
be\'franklin
&%^$@#!*&^'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end