import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[A-Za-z0-9]).{3,30}$";
final String string = "ben\n"
+ "ab\n"
+ "ben \n"
+ "ben_franklin\n"
+ "ben@\n"
+ "%#$\n"
+ "ben#franklin\n"
+ "be'franklin\n"
+ "&%^$@#!*&^";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}