using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:.*(?:AND|OR|NOT)\s+\K)?.*";
string input = @"k:v AND k1:v1 AND NOT k2:v2 OR k3:v3";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}