re = /(?:.*(?:AND|OR|NOT)\s+\K)?.*/
str = 'k:v AND k1:v1 AND NOT k2:v2 OR k3:v3'
# Print the match result
str.match(re) do |match|
puts match.to_s
end