import Foundation
let pattern = #"(?:.*(?:AND|OR|NOT)\s+\K)?.*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"k:v AND k1:v1 AND NOT k2:v2 OR k3:v3"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}