$re = '/(?:.*(?:AND|OR|NOT)\s+\K)?.*/';
$str = 'k:v AND k1:v1 AND NOT k2:v2 OR k3:v3';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);