const regex = /(?:.*(?:AND|OR|NOT)\s+\K)?.*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:.*(?:AND|OR|NOT)\\s+\\K)?.*', '')
const str = `k:v AND k1:v1 AND NOT k2:v2 OR k3:v3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}