using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\+?\d{0,2})?[\D]?\(?(\d{3})\)?[\D]?(\d{3})[\D]?(\d{4})$";
string substitution = @"$1 $2-$3-$4";
string input = @"(000) 000 0000
(000) 000-0000
(000)000 0000
(000)000-0000
(000)0000000
+0 (000) 000-0000
+0 000 000 0000
+0 000-000-0000
+0-000-000-0000
+00 (000) 000-0000
+00 000 0000000
+00 0000000000
+0000000000
+000000000000
0 (000) 000-0000
0 (000)-000-0000
0 0000000000
0-000-000-0000
000 000 0000
000 000-0000
000-000 0000
000-000-0000
000-0000000
000.000.0000
000000-0000
0000000000";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}