$re = '/^(\+?\d{0,2})?[\D]?\(?(\d{3})\)?[\D]?(\d{3})[\D]?(\d{4})$/m';
$str = '(000) 000 0000
(000) 000-0000
(000)000 0000
(000)000-0000
(000)0000000
+0 (000) 000-0000
+0 000 000 0000
+0 000-000-0000
+0-000-000-0000
+00 (000) 000-0000
+00 000 0000000
+00 0000000000
+0000000000
+000000000000
0 (000) 000-0000
0 (000)-000-0000
0 0000000000
0-000-000-0000
000 000 0000
000 000-0000
000-000 0000
000-000-0000
000-0000000
000.000.0000
000000-0000
0000000000';
$subst = "$1 $2-$3-$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;