# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\+?\d{0,2})?[\D]?\(?(\d{3})\)?[\D]?(\d{3})[\D]?(\d{4})$"
test_str = ("(000) 000 0000\n"
"(000) 000-0000\n"
"(000)000 0000\n"
"(000)000-0000\n"
"(000)0000000\n"
"+0 (000) 000-0000\n"
"+0 000 000 0000\n"
"+0 000-000-0000\n"
"+0-000-000-0000\n"
"+00 (000) 000-0000\n"
"+00 000 0000000\n"
"+00 0000000000\n"
"+0000000000\n"
"+000000000000\n"
"0 (000) 000-0000\n"
"0 (000)-000-0000\n"
"0 0000000000\n"
"0-000-000-0000\n"
"000 000 0000\n"
"000 000-0000\n"
"000-000 0000\n"
"000-000-0000\n"
"000-0000000\n"
"000.000.0000\n"
"000000-0000\n"
"0000000000")
subst = "$1 $2-$3-$4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.