const regex = /^(\+?\d{0,2})?[\D]?\(?(\d{3})\)?[\D]?(\d{3})[\D]?(\d{4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+?\\d{0,2})?[\\D]?\\(?(\\d{3})\\)?[\\D]?(\\d{3})[\\D]?(\\d{4})$', 'gm')
const str = `(000) 000 0000
(000) 000-0000
(000)000 0000
(000)000-0000
(000)0000000
+0 (000) 000-0000
+0 000 000 0000
+0 000-000-0000
+0-000-000-0000
+00 (000) 000-0000
+00 000 0000000
+00 0000000000
+0000000000
+000000000000
0 (000) 000-0000
0 (000)-000-0000
0 0000000000
0-000-000-0000
000 000 0000
000 000-0000
000-000 0000
000-000-0000
000-0000000
000.000.0000
000000-0000
0000000000`;
const subst = `$1 $2-$3-$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);