#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([A-Z0-9 #]+) \[([A-Za-z0-9 .]+)\]([\S])"
Local $sString = "- MAN [on radio]: The signal is breaking up." & @CRLF & _
"" & @CRLF & _
"MAN #2 [on radio]: Stay on him." & @CRLF & _
""
Local $sSubst = "[\L$1\E $2]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)