// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([A-Z0-9 #]+) \[([A-Za-z0-9 .]+)\]([\S])").unwrap();
let string = "- MAN [on radio]: The signal is breaking up.
MAN #2 [on radio]: Stay on him.
";
let substitution = "[\\L$1\\E $2]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}