using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z0-9 #]+) \[([A-Za-z0-9 .]+)\]([\S])";
string substitution = @"[\L$1\E $2]";
string input = @"- MAN [on radio]: The signal is breaking up.
MAN #2 [on radio]: Stay on him.
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}