import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z0-9 #]+) \\[([A-Za-z0-9 .]+)\\]([\\S])";
final String string = "- MAN [on radio]: The signal is breaking up.\n\n"
+ "MAN #2 [on radio]: Stay on him.\n";
final String subst = "[\\L$1\\E $2]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}