using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(?:\s*,\s*\d+)+(*SKIP)(*F)|,";
string substitution = @"";
string input = @"a,b,,c 1, 3 , 5 ,6";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}