// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+(?:\s*,\s*\d+)+(*SKIP)(*F)|,").unwrap();
let string = "a,b,,c 1, 3 , 5 ,6";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}