import Foundation
let pattern = #"\d+(?:\s*,\s*\d+)+(*SKIP)(*F)|,"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"a,b,,c 1, 3 , 5 ,6"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)