$re = '/\d+(?:\s*,\s*\d+)+(*SKIP)(*F)|,/m';
$str = 'a,b,,c 1, 3 , 5 ,6';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;