import Foundation
let pattern = #"id="loginToken".*?value="(.*?)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<span id="loginToken"><input name="__RequestVerificationToken" type="hidden" value="kL5UknRMXsBy5QUMtDFPuBwESd89jK5l1VyF7SliGL8g0NCE-pnbowPMPtEMpi2Nmm9F_626FN-cQ6-miwS-CXXkQUM1" /></span>
<span id="registerToken"><input name="__RequestVerificationToken" type="hidden" value="JDJD9khCZNjXeFGLMcBbqDqNmgR19Z-wy4FueH1CkWCdQQry_cgnKHLuj7uyrquk_gzDotKxN1ZQO8rPEc3fsH21uXc1" /></span>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)