import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:and|where)\\s+Table\\.Field(*SKIP)(*F)|Table\\.Field";
final String string = "Must match\n"
+ "Table.Field\n"
+ "something Table.Field\n"
+ " bTable.Field\n"
+ "Table.Field\n\n"
+ "bandTable.Field\n\n"
+ "Must not match\n"
+ "and Table.Field\n"
+ "where Table.Field\n"
+ "and Table.Field\n"
+ "where Table.Field";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}